Stamps.com System Status

Welcome to Stamps.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

Stamps.com Account Registration Issue

Incident Report for Status.Stamps.com

Resolved

Stamps.com Engineers have resolved the account registration issue. We apologize for the inconvenience and thank you for your patience. If you are still having issues, please contact us.
Posted Aug 22, 2025 - 18:02 PDT

Investigating

We are aware of an issue impacting new customer account creation and are investigating. If your account creation failed, please try again in the next hour.
Posted Aug 22, 2025 - 16:58 PDT
This incident affected: Stamps.com API (SWS/Web Services).