System Status

Welcome to Stamps.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Transaction Print History Delays
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have fixed the print history delay issue and all systems are functioning normally. Thanks for your patience!
Posted 11 months ago. Nov 16, 2018 - 10:14 PST
Identified
We have identified the root cause of the issue and are continuing to work on a fix for this issue.
Posted 11 months ago. Nov 16, 2018 - 09:49 PST
Investigating
Stamps.com Engineers have identified an issue that may affect some of our customers' ability to see transactions in their Printed Postage History Report, Refund Section, and SCAN Form. Sorry for the inconvenience – we’ll have a solution for this soon!
Posted 11 months ago. Nov 16, 2018 - 08:22 PST
This incident affected: Stamps.com Reporting Tools (Postage History, Refunds & SCAN Forms).