System Status

Welcome to Stamps.com's home for real-time information on system status. If there are any interruptions in service, a note will be posted here.


Subscribing to Email & SMS Updates - Please "confirm" your subscription by responding to the Email we send after you sign-up for alerts. To receive alert texts on your mobile phone, you will also need to reply back "YES" to the text confirmation.

Issues Printing Postage
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have fixed the printing issue and all systems are functioning normally. Thanks for your patience!
Posted 4 months ago. Mar 07, 2018 - 11:08 PST
Investigating
Stamps.com Engineers have identified an issue that may temporarily affect some of our customers' ability to print postage and shipping labels from the software. Sorry for the inconvenience – we’ll have a solution for this soon!
Posted 4 months ago. Mar 07, 2018 - 10:56 PST