Login Issues
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have fixed the login issue and all systems are functioning normally. Thanks for your patience!
Posted Apr 18, 2018 - 21:13 PDT
Identified
Our Engineers have identified an issue that may temporarily affect some of our customers' ability to login into the Stamps.com software and website. Sorry for the inconvenience – we’ll have a solution for this soon!
Posted Apr 18, 2018 - 20:14 PDT