System Status

Welcome to Stamp.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Order Postback Delays
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have fixed the issue and all order postbacks are going through. Stamps.com is now functioning normally. Thanks for your patience!
Posted 4 months ago. Oct 19, 2018 - 12:28 PDT
Update
We have identified the root cause issue and are continuing to work on a fix for this issue.
Posted 4 months ago. Oct 19, 2018 - 11:31 PDT
Identified
Stamps.com Engineers are investigating an issue that may delay some of our customers' using our Orders the ability to postback orders. Sorry for the inconvenience – we’ll have a solution for this soon!
Posted 4 months ago. Oct 19, 2018 - 09:20 PDT
This incident affected: Stamps.com Online (Printing Postage Using a Web Browser) and Stamps.com Software (Printing Postage Using our Windows Application).