System Status

Welcome to Stamp.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Login Issues
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have identified and fixed the login issue and all systems are functioning normally. Thanks for your patience!
Posted 11 months ago. Jan 12, 2018 - 11:47 PST
Investigating
Some customers have reported an issue that may temporarily affect their ability to login into the to Stamps.com software and website. Sorry for the inconvenience – we’ll have a solution for this soon!
Posted 11 months ago. Jan 12, 2018 - 11:40 PST