System Status

Welcome to Stamp.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Postage Purchase Delays
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have been informed by a third party of the fix for the postage purchase issue and all systems are functioning normally. Thanks for your patience!
Posted 8 days ago. Jul 12, 2018 - 12:32 PDT
Identified
Stamps.com Engineers have identified a third party issue that may temporarily affect some of our customers' ability to purchase postage. Sorry for the inconvenience – we’ll have a solution for this soon!
Posted 8 days ago. Jul 12, 2018 - 11:42 PDT
This incident affected: Stamps.com Reporting Tools (Postage History, Refunds & SCAN Forms).