Stamps.com System Status

Welcome to Stamps.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

Unexpected Technical Problem | Stamps.com Store

Incident Report for Status.Stamps.com

Resolved

This incident has been resolved.
Posted Nov 01, 2022 - 15:21 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 01, 2022 - 09:12 PDT

Update

We are continuing to investigate this issue.
Posted Oct 31, 2022 - 10:44 PDT

Investigating

The systems that monitor the Stamps.com service indicate that there may be a problem that may impact some customers’ ability to use the Stamps.com Store service. We are working to quickly resolve this issue and will provide an update when it is available. We apologize for the inconvenience.
Posted Oct 31, 2022 - 08:51 PDT