Blank History Page Viewing Today's Prints
Incident Report for Status.Stamps.com
Resolved
This incident has been resolved.
Posted May 14, 2024 - 10:42 PDT
Update
Developers are continuing to investigate issues related to an inability to load print history on our web application.
Posted May 14, 2024 - 10:05 PDT
Investigating
We are currently investigating this issue.
Posted May 14, 2024 - 06:45 PDT
This incident affected: Stamps.com Reporting Tools (Postage History, Refunds & SCAN Forms).