Stamps.com System Status

Welcome to Stamps.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

USPS Service to Canada Resumes 1/6/25

Incident Report for Status.Stamps.com

Resolved

This incident has been resolved.
Posted Jan 17, 2025 - 14:39 PST

Monitoring

Effective Monday, January 6, 2025, USPS will resume full service to Canada and begin accepting mail and packages again. Starting Monday, January 6, 2025, you can create and print USPS labels destined for Canada using your Stamps account. Please note that due to the recent CUPW strike and accumulated backlog, shipments may experience delays.

Effective Monday, January 6, 2025, GlobalPost has resumed full service to Canada, including P.O. Boxes and previously restricted postal codes, and is now accepting mail and packages again for these destinations.
Posted Nov 27, 2024 - 16:54 PST
This incident affected: Stamps.com Online (Printing Postage Using a Web Browser), Stamps.com Software (Printing Postage Using our Windows Application), and Stamps.com API (SWS/Web Services).