Unexpected Technical Problem
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have fixed the technical issue and all systems are functioning normally. Thank you for your patience.
Posted Jan 25, 2021 - 19:39 PST
Update
The systems that monitor the Stamps.com service are indicating that there may be a problem that may impact some customers’ ability to print internationally. We are working to quickly resolve this issue and will provide an update when it is available. We apologize for the inconvenience.
Posted Jan 25, 2021 - 14:05 PST
Investigating
The systems that monitor the Stamps.com service are indicating that there may be a problem that may impact some customers’ ability to use the service. We are working to quickly resolve this issue and will provide an update when it is available. We apologize for the inconvenience.
Posted Jan 25, 2021 - 12:24 PST
This incident affected: Stamps.com Online (Printing Postage Using a Web Browser).