System Status

Welcome to Stamps.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Stamps.com software - History page blank
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have fixed the technical issue and all systems are functioning normally. Thanks for your patience!
Posted 6 months ago. Apr 22, 2019 - 11:55 PDT
Identified
The Print History loading blank page in the Win Client software has been identified and a fix is being implemented.
Posted 6 months ago. Apr 22, 2019 - 11:24 PDT
Update
We are continuing to investigate this issue. In the meantime, please try uninstalling and installing the latest version of the software client. The latest software can be downloaded at www.stamps.com/download. Another workaround is to login to an external browser e.g. Google Chrome to view your Print History.
Posted 6 months ago. Apr 20, 2019 - 07:40 PDT
Investigating
We are currently investigating reported behavior with the Stamps.com software page being blank
Posted 6 months ago. Apr 19, 2019 - 13:57 PDT
This incident affected: Stamps.com Reporting Tools (Postage History, Refunds & SCAN Forms).