Issues Printing UPS Postage
Incident Report for Status.Stamps.com
Resolved
This incident has been resolved.
Posted Jun 06, 2024 - 09:59 PDT
Update
Stamps.com is aware of the technical issues impacting UPS label creation. We are actively monitoring the status of this issue and will provide updates as they become available. Thank you for your patience!
Posted Jun 06, 2024 - 09:42 PDT
Investigating
Stamps.com is investigating technical issues impacting UPS label creation.
Posted Jun 06, 2024 - 09:40 PDT
This incident affected: Stamps.com Online (Printing Postage Using a Web Browser), Stamps.com Software (Printing Postage Using our Windows Application), and Stamps.com API (SWS/Web Services).