Stamps.com System Status

Welcome to Stamps.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

E-Mails Not Being Sent

Incident Report for Status.Stamps.com

Resolved

This incident has been resolved.
Posted Apr 24, 2025 - 05:19 PDT

Investigating

We are aware of an issue impacting the ability to receive emails from Stamps.com, including authentication codes. This is due to an outage by our third-party email provider. We are monitoring the outage and will provide an update as soon as one is available.
Posted Apr 23, 2025 - 15:06 PDT
This incident affected: Stamps.com Online (Printing Postage Using a Web Browser) and Stamps.com Software (Printing Postage Using our Windows Application).