Transaction Print History Delays
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have fixed the print history delay issue and all systems are functioning normally. Thanks for your patience!
Posted Nov 19, 2018 - 07:48 PST
Identified
We have identified the root cause of the issue and are continuing to work on a fix for this issue.
Posted Nov 19, 2018 - 07:19 PST
Investigating
Stamps.com Engineers have identified an issue that may affect some of our customers' ability to see recent transactions in their Printed Postage History Report, Refund Section, and SCAN Form. Sorry for the inconvenience – we’ll have a solution for this soon!
Posted Nov 19, 2018 - 06:20 PST
This incident affected: Stamps.com Reporting Tools (Postage History, Refunds & SCAN Forms).