Unexpected Technical Problem | Stamps.com Store
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have fixed the technical issue and all systems are functioning normally. Thank you for your patience.
Posted Nov 10, 2022 - 18:15 PST
Update
We are continuing to investigate this issue.
Posted Nov 10, 2022 - 13:52 PST
Investigating
The systems that monitor the Stamps.com service indicate that there may be a problem that may impact some customers’ ability to use the Stamps.com Store service. We are working to quickly resolve this issue and will provide an update when it is available. We apologize for the inconvenience.
Posted Nov 10, 2022 - 10:43 PST