System Status

Welcome to Stamps.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Unexpected Technical Problem
Incident Report for Status.Stamps.com
Resolved
This incident has been resolved.
Posted Nov 06, 2019 - 13:57 PST
Investigating
Stamps.com is currently experiencing a technical issue preventing the SUPPLIES pages and Manage Account pages from loading. Some users are reporting a "502 Bad Gateway" error that we are working to resolve. Our engineering team is working to resolve this issue as quickly as possible. We’ll share another update shortly.
Posted Nov 06, 2019 - 13:39 PST