System Status

Welcome to Stamps.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Postage Purchase Delays
Incident Report for Status.Stamps.com
Resolved
This incident has been resolved.
Posted 6 days ago. Aug 13, 2019 - 00:49 PDT
Investigating
Due to scheduled maintenance, postage purchases may take up to one minute to reflect in your postage balance. You may need to logout of the system and log back in to see your updated balance.
Posted 6 days ago. Aug 12, 2019 - 19:14 PDT
This incident affected: Stamps.com API (SWS/Web Services) and Stamps.com Reporting Tools (Postage History, Refunds & SCAN Forms).