Unexpected Technical Problem
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have fixed the technical issue and all systems are functioning normally. Thanks for your patience!
Posted Oct 22, 2019 - 11:34 PDT
Investigating
Stamps.com is currently experiencing a technical issue that we are working to resolve. Our engineering team is working to resolve this issue as quickly as possible. We’ll share another update shortly.
Posted Oct 22, 2019 - 11:03 PDT
This incident affected: Stamps.com Reporting Tools (Postage History, Refunds & SCAN Forms).