Stamps.com System Status

Welcome to Stamp.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

USPS Temporarily Suspends Service on 1/9/25
Incident Report for Status.Stamps.com
Resolved
This incident has been resolved.
Posted Jan 10, 2025 - 15:03 PST
Monitoring
In honor of former President, Jimmy Carter, USPS will observe a National Day of Observance on Thursday, January 9th. On this day, mail deliveries, retail services, and administrative office activity will be temporarily suspended. Commercial drop-offs will continue to be accepted and processed and limited package delivery will occur to prevent impacts.

Regular operations will resume on Friday, January 10th. More info: https://postalpro.usps.com/node/13715
Posted Jan 07, 2025 - 15:25 PST