Stamps.com System Status

Welcome to Stamps.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

Stamps Classic Order Page Auth Failure

Incident Report for Status.Stamps.com

Resolved

This incident has been resolved.
Posted Jan 21, 2026 - 06:17 PST

Update

Stamps.com Engineers are working towards implementing a fix.
Posted Jan 20, 2026 - 18:00 PST

Update

Stamps.com Engineers are working towards implementing a fix.
Posted Jan 20, 2026 - 10:15 PST

Monitoring

Stamps.com Engineers have identified an issue that may temporarily affect some of our customers' ability to connect new store profiles or import orders within the Stamps Classic Software. Stamps.com Engineers have identified the issue and are working at implementing a fix.
Posted Jan 20, 2026 - 14:13 PST

Investigating

Stamps.com Engineers have identified an issue that may temporarily affect some of our customers' ability to connect new store profiles or import orders within the Stamps Classic Software. Stamps.com
Posted Jan 19, 2026 - 08:30 PST
This incident affected: Stamps.com Software (Printing Postage Using our Windows Application).