System Status

Welcome to Stamps.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Stamps.com - Unable to print or purchase postage
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have fixed the postage printing issue and all systems are functioning normally. Thanks for your patience!
Posted 19 days ago. Sep 27, 2019 - 15:57 PDT
Update
We are continuing to investigate this issue.
Posted 19 days ago. Sep 27, 2019 - 09:09 PDT
Investigating
At the present time we are investigating reports of customers unable to print or purchase postage from the software or web interface. We appreciate your patience while this behavior is corrected.
Posted 19 days ago. Sep 27, 2019 - 08:53 PDT
This incident affected: Stamps.com Online (Printing Postage Using a Web Browser), Stamps.com Software (Printing Postage Using our Windows Application), and Stamps.com API (SWS/Web Services).