System Status

Welcome to Stamps.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Login Issues
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have fixed the login issue and all systems are functioning normally. Thanks for your patience!
Posted about 1 year ago. Jun 27, 2018 - 10:29 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted about 1 year ago. Jun 27, 2018 - 09:56 PDT
Investigating
Our Engineers have identified an issue that may temporarily affect some of our customers' ability to login into the Stamps.com software and website. Sorry for the inconvenience – we’ll have a solution for this soon!
Posted about 1 year ago. Jun 27, 2018 - 09:04 PDT
This incident affected: Stamps.com Online (Printing Postage Using a Web Browser), Stamps.com Software (Printing Postage Using our Windows Application), and Stamps.com API (SWS/Web Services).