Login Issues
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have resolved the log in issue. We apologize for the inconvenience and thank you for your patience. If you are still having issues, please contact us.
Posted Dec 15, 2021 - 08:31 PST
Investigating
Our Engineers have identified an issue that may affect some of our customers' ability to login into their Stamps.com account. We are working to quickly resolve this issue and will provide an update when it is available. We apologize for the inconvenience.
Posted Dec 15, 2021 - 08:03 PST
This incident affected: Stamps.com Online (Printing Postage Using a Web Browser), Stamps.com Software (Printing Postage Using our Windows Application), Stamps.com API (SWS/Web Services), and Stamps.com Reporting Tools (Postage History, Refunds & SCAN Forms).