Unexpected Store Technical Problem
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have fixed the technical issue and all systems are functioning normally. Thanks for your patience!
Posted Jan 30, 2020 - 14:40 PST
Investigating
Stamps.com is currently experiencing a technical issue with our online store. We are working to resolve and our engineering team is working to resolve this issue as quickly as possible. We’ll share another update shortly.
Posted Jan 30, 2020 - 14:26 PST