Stamps.com System Status

Welcome to Stamps.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

Customers are currently unable to add new payment methods.

Incident Report for Status.Stamps.com

Resolved

This incident has been resolved.
Posted Nov 06, 2025 - 10:12 PST

Investigating

We are aware of an issue impacting the ability to add a new payment method to your Stamps account. Our engineers are currently investigating and an update will be provided as soon as one is available.
Posted Nov 06, 2025 - 09:34 PST