Issues Printing Postage with UPS
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have been notified that the postage printing issues involving UPS services have been resolved. We apologize for the inconvenience and thank you for your patience.
Posted Jul 29, 2024 - 11:42 PDT
Investigating
Stamps.com Engineers are aware of an issue that may temporarily affect some of our customers' ability to generate rates for UPS rates for domestic or international shipments. We will provide an update when one is available.
Posted Jul 29, 2024 - 11:00 PDT
This incident affected: Stamps.com Online (Printing Postage Using a Web Browser), Stamps.com Software (Printing Postage Using our Windows Application), and Stamps.com API (SWS/Web Services).