System Status

Welcome to Stamp.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Order Import Delays
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have fixed the issue and all orders are being imported in real-time. Stamps.com is now functioning normally. Thanks for your patience!
Posted 8 days ago. Aug 07, 2018 - 14:23 PDT
Update
We are continuing to investigate this issue.
Posted 8 days ago. Aug 07, 2018 - 09:55 PDT
Investigating
Stamps.com Engineers are investigating an issue that may delay some of our customers' using our software the ability to import orders from Amazon. Sorry for the inconvenience – we’ll have a solution for this soon!
Posted 8 days ago. Aug 07, 2018 - 08:53 PDT
This incident affected: Stamps.com Software (Printing Postage Using our Windows Application).