Stamps.com System Status

Welcome to Stamps.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

Unexpected Technical Problem

Incident Report for Status.Stamps.com

Resolved

This incident has been resolved.
Posted Jul 07, 2025 - 10:12 PDT

Update

We are continuing to investigate this issue.
Posted Jul 07, 2025 - 06:57 PDT

Investigating

We are aware of a problem that may impact some customers’ ability to create a Scan Form on Stamps.com service. We are monitoring this issue and will provide an update when it is available. We apologize for the inconvenience.
Posted Jul 07, 2025 - 06:47 PDT
This incident affected: Stamps.com API (SWS/Web Services) and Stamps.com Reporting Tools (Postage History, Refunds & SCAN Forms).