Issues Printing Postage
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have fixed the postage printing issue. We apologize for the inconvenience and thank you for your patience. If you are still having issues, please contact us.
Posted Jul 21, 2021 - 14:00 PDT
Investigating
Stamps.com Engineers have identified an issue that may temporarily affect some of our customers' ability to print postage and shipping labels. We are working to quickly resolve this issue and will provide an update when it is available. We apologize for the inconvenience.
Posted Jul 21, 2021 - 13:52 PDT
This incident affected: Stamps.com Online (Printing Postage Using a Web Browser) and Stamps.com Software (Printing Postage Using our Windows Application).