System Status

Welcome to Stamp.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Unexpected Technical Problem
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have fixed the technical issue and all systems are functioning normally. Thanks for your patience!
Posted 4 months ago. Dec 10, 2018 - 12:34 PST
Investigating
Some Stamps.com customers are experiencing intermittent slowness that we are working to resolve. Our engineering team is working to resolve this issue as quickly as possible. We’ll share another update shortly.
Posted 4 months ago. Dec 10, 2018 - 12:12 PST
This incident affected: Stamps.com Online (Printing Postage Using a Web Browser).