Unexpected Technical Problem
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have resolved the log in issue. We apologize for the inconvenience and thank you for your patience. If you are still having issues, please contact us.
Posted Aug 23, 2021 - 06:53 PDT
Update
We are continuing to investigate this issue.
Posted Aug 23, 2021 - 06:52 PDT
Investigating
Our Engineers have identified an issue that may temporarily affect some of our customers' ability to login into the Stamps.com software. Sorry for the inconvenience – we’ll have a solution for this soon!
Posted Aug 23, 2021 - 05:11 PDT
This incident affected: Stamps.com Software (Printing Postage Using our Windows Application).