Stamps.com System Status

Welcome to Stamps.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

Phone Support Outage

Incident Report for Status.Stamps.com

Resolved

This incident has been resolved.
Posted Apr 16, 2025 - 13:48 PDT

Investigating

Due to an outage with our phone service provider, Stamps Phone Support is currently down. We sincerely apologize for any inconvenience, and look forward to assisting you through our other channels. Please login to your Stamps account and use the Chat option, or email support@stamps.com for any urgent inquiries.
Posted Apr 16, 2025 - 12:20 PDT