System Status

Welcome to Stamps.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Order Import Delays
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have fixed the issue and all orders are being imported in real-time. Stamps.com is now functioning normally. Thanks for your patience!
Posted 3 months ago. Jul 02, 2019 - 09:32 PDT
Identified
Stamps.com Engineers have identified an issue that may delay some of our customers' ability to import orders. Sorry for the inconvenience – we’ll have a solution for this soon!
Posted 3 months ago. Jul 02, 2019 - 08:45 PDT
This incident affected: Stamps.com Online (Printing Postage Using a Web Browser).