System Status

Welcome to Stamp.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Issues Printing Postage Online
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have fixed the postage printing issue and all systems are functioning normally. Thanks for your patience!
Posted 15 days ago. Jul 05, 2018 - 16:51 PDT
Investigating
Stamps.com Engineers are investigating an issue that may temporarily affect some of our Mac customers' ability to print postage and shipping labels online. Sorry for the inconvenience – we’ll have a solution for this soon!
Posted 15 days ago. Jul 05, 2018 - 16:17 PDT
This incident affected: Stamps.com Online (Printing Postage Using a Web Browser).