Unexpected Technical Problem on Orders Page
Incident Report for Status.Stamps.com
Resolved
This incident has been resolved.
Posted Dec 22, 2022 - 12:49 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 22, 2022 - 12:09 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 22, 2022 - 12:06 PST
Investigating
The systems that monitor the Stamps.com service are indicating that there may be a problem that may impact some customers’ ability to use the service. We are working to quickly resolve this issue and will provide an update when it is available. We apologize for the inconvenience.
Posted Dec 22, 2022 - 11:54 PST
This incident affected: Stamps.com Online (Printing Postage Using a Web Browser).