System Status

Welcome to Stamps.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

SCAN Form Issue | Unexpected Technical Problem
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have fixed the SCAN Form technical issue and all systems are functioning normally. Thanks for your patience!
Posted Jul 08, 2019 - 13:35 PDT
Investigating
Stamps.com is currently experiencing a technical issue in generating SCAN Forms that we are working to resolve. Our engineering team is working to resolve this issue as quickly as possible. We’ll share another update shortly.
Posted Jul 08, 2019 - 13:00 PDT
This incident affected: Stamps.com API (SWS/Web Services) and Stamps.com Reporting Tools (Postage History, Refunds & SCAN Forms).