Unexpected Technical Problem
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have fixed the technical issue and all systems are functioning normally. Thanks for your patience!
Posted Jun 05, 2019 - 11:36 PDT
Identified
Stamps.com is currently experiencing a technical issue that we are working to resolve. Our engineering team is working to resolve this issue as quickly as possible. We’ll share another update shortly.
Posted Jun 05, 2019 - 11:22 PDT
This incident affected: Stamps.com Online (Printing Postage Using a Web Browser) and Stamps.com Software (Printing Postage Using our Windows Application).