System Status

Welcome to Stamps.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Order Import Delays
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have fixed the issue and all orders are being imported in real-time. Stamps.com is now functioning normally. Thanks for your patience!
Posted 9 months ago. Nov 30, 2018 - 20:21 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 9 months ago. Nov 30, 2018 - 14:10 PST
Update
Stamps.com Engineers are continuing to identify the issue that may delay some of our customers' ability to import orders from. Sorry for the inconvenience – we’ll have a solution for this soon!
Posted 9 months ago. Nov 30, 2018 - 09:43 PST
Identified
The issue has been identified and a fix is being implemented.
Posted 9 months ago. Nov 30, 2018 - 07:28 PST
Investigating
Stamps.com Engineers have identified an issue that may delay some of our customers' ability to import orders from Store Marketplaces (e.g. eBay, Amazon). Sorry for the inconvenience – we’ll have a solution for this soon!
Posted 9 months ago. Nov 30, 2018 - 06:30 PST
This incident affected: Stamps.com Software (Printing Postage Using our Windows Application).