Unexpected Technical Problem with Etsy on Orders Page
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have fixed the issue with Etsy and all orders should import normally, a refresh may be required. We apologize for the inconvenience and thank you for your patience. If you are still experiencing an issue please contact our customer support.
Posted Apr 28, 2023 - 15:41 PDT
Update
Stamps.com Engineers have identified an issue that may affect importing orders and connecting to Etsy on the Orders page. We are working to quickly resolve this issue and will provide an update when it is available. We apologize for the inconvenience.
Posted Apr 19, 2023 - 14:08 PDT
Investigating
Stamps.com Engineers have identified an issue that may affect importing orders and connecting to Etsy on the Orders page. We are working to quickly resolve this issue and will provide an update when it is available. We apologize for the inconvenience.
Posted Apr 11, 2023 - 11:29 PDT
This incident affected: Stamps.com Online (Printing Postage Using a Web Browser) and Stamps.com Software (Printing Postage Using our Windows Application).