Order Import Delays
Incident Report for Status.Stamps.com
Resolved
This incident has been resolved.
Posted Aug 23, 2024 - 13:07 PDT
Investigating
Stamps.com Engineers have identified an issue that may delay some of our customers' ability to import orders using CSV files. We are working to quickly resolve this issue and will provide an update when it is available.  We apologize for the inconvenience.
Posted Aug 23, 2024 - 11:37 PDT
This incident affected: Stamps.com Online (Printing Postage Using a Web Browser).