System Status

Welcome to Stamp.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Recent Prints Missing from History
Incident Report for Status.Stamps.com
Resolved
Our Engineers have identified and resolved the Print History issue as of 7:50 AM Pacific time.
Posted 2 months ago. Oct 11, 2018 - 08:05 PDT
Investigating
We are currently investigating reports of Recent activity missing from the History page.
Posted 2 months ago. Oct 11, 2018 - 07:01 PDT
This incident affected: Stamps.com Reporting Tools (Postage History, Refunds & SCAN Forms).