Issues Printing Postage
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have fixed the postage printing issue and all systems are functioning normally. Thanks for your patience!
Posted Sep 18, 2020 - 11:54 PDT
Investigating
Stamps.com Engineers have identified an issue that may temporarily affect some of our customers' ability to print postage and shipping labels. Sorry for the inconvenience – we’ll have a solution for this soon!
Posted Sep 18, 2020 - 11:03 PDT
This incident affected: Stamps.com Online (Printing Postage Using a Web Browser), Stamps.com Software (Printing Postage Using our Windows Application), Stamps.com API (SWS/Web Services), and Stamps.com Reporting Tools (Postage History, Refunds & SCAN Forms).