The earlier AWS-related service disruption has been resolved. Endicia software and API operations have returned to normal as of 15:53 PDT, according to AWS. We’ll continue to monitor for stability, but no further impact is expected.
Posted Oct 20, 2025 - 18:22 PDT
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 18:03 PDT
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 18:00 PDT
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 17:30 PDT
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 17:00 PDT
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 16:30 PDT
Monitoring
Stamps software may currently be experiencing some performance issues due to the ongoing AWS service issue. We are actively monitoring their status and its impact on our platform. We will provide updates as they become available.