Login Issues
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have fixed the login issue and all systems are functioning normally. Thanks for your patience!
Posted Jun 26, 2020 - 14:19 PDT
Investigating
Our Engineers have identified an issue that may temporarily affect some of our customers' ability to login into the Stamps.com software and website. Sorry for the inconvenience – we’ll have a solution for this soon!
Posted Jun 26, 2020 - 13:04 PDT
This incident affected: Stamps.com Online (Printing Postage Using a Web Browser), Stamps.com Software (Printing Postage Using our Windows Application), and Stamps.com API (SWS/Web Services).