Stamps.com System Status

Welcome to Stamps.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

Unexpected Technical Problem Loading Manage Account

Incident Report for Status.Stamps.com

Resolved

Stamps.com Engineers have fixed the technical issue and all systems are functioning normally. Thank you for your patience.
Posted Sep 20, 2021 - 09:30 PDT

Update

We are continuing to investigate the issue with loading the Manage Account page.
Posted Sep 20, 2021 - 08:37 PDT

Investigating

The systems that monitor the Stamps.com service are indicating that there may be a problem that may impact some customers’ ability to use the Manage Account service. We are working to quickly resolve this issue and will provide an update when it is available. We apologize for the inconvenience.
Posted Sep 20, 2021 - 07:56 PDT