Stamps Windows Software - Issue Importing E-Commerce Store Orders
Incident Report for Status.Stamps.com
Resolved
This incident has been resolved.
Posted May 30, 2024 - 15:56 PDT
Investigating
Our engineers have identified an issue affecting the importing of e-commerce webstore orders. The issue has been identified and engineers are actively working on the fix.
Posted May 30, 2024 - 11:36 PDT
This incident affected: Stamps.com Software (Printing Postage Using our Windows Application).