System Status

Welcome to Stamp.com’s home for real-time information on system status. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Login Issues
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have fixed the login issue and all systems are functioning normally. Thanks for your patience!
Posted 3 months ago. Jul 30, 2018 - 10:26 PDT
Update
We are continuing to investigate this issue.
Posted 3 months ago. Jul 30, 2018 - 08:53 PDT
Investigating
Our Engineers have identified an issue that may temporarily affect some of our customers' ability to login into the Stamps.com website. Sorry for the inconvenience – we’ll have a solution for this soon!
Posted 3 months ago. Jul 30, 2018 - 07:39 PDT
This incident affected: Stamps.com Online (Printing Postage Using a Web Browser).