Order Import Delays
Incident Report for Status.Stamps.com
Resolved
Stamps.com Engineers have fixed the issue and all orders are being imported in real-time. Stamps.com is now functioning normally. Thanks for your patience!
Posted Mar 15, 2019 - 20:39 PDT
Investigating
Stamps.com Engineers have identified an issue that may delay some of our customers' ability to import orders from Amazon, Ebay, and Etsy. Sorry for the inconvenience – we’ll have a solution for this soon!
Posted Mar 15, 2019 - 16:18 PDT
This incident affected: Stamps.com Online (Printing Postage Using a Web Browser).