Login Issues
Incident Report for Status.Stamps.com
Resolved
This incident has been resolved.
Posted Oct 22, 2021 - 09:55 PDT
Update
We are continuing to investigate this issue.
Posted Oct 22, 2021 - 09:55 PDT
Investigating
Our Engineers have identified an issue that may affect some of our customers' ability to login into their Stamps.com account. We are working to quickly resolve this issue and will provide an update when it is available. We apologize for the inconvenience.
Posted Oct 22, 2021 - 06:44 PDT
This incident affected: Stamps.com Online (Printing Postage Using a Web Browser) and Stamps.com Software (Printing Postage Using our Windows Application).